summaryrefslogtreecommitdiff
path: root/media-gfx/crwinfo/crwinfo-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/crwinfo/crwinfo-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/crwinfo/crwinfo-0.2.ebuild')
-rw-r--r--media-gfx/crwinfo/crwinfo-0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/crwinfo/crwinfo-0.2.ebuild b/media-gfx/crwinfo/crwinfo-0.2.ebuild
new file mode 100644
index 000000000000..e3c6aed17fe3
--- /dev/null
+++ b/media-gfx/crwinfo/crwinfo-0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
+HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
+SRC_URI="http://neuemuenze.heim1.tu-clausthal.de/~sven/crwinfo/CRWInfo-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64 alpha ia64 hppa ppc64"
+IUSE=""
+
+S="${WORKDIR}/CRWInfo-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+ sed \
+ -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin crwinfo
+ dodoc README spec
+}