summaryrefslogtreecommitdiff
path: root/media-gfx/cropgui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
commit65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (patch)
tree541cbae0eb51d2fdb39d64b3d135d1a6f7994dc8 /media-gfx/cropgui
parent0aad4cd3e3fe3db90904ffc51b35e4ff160b53c5 (diff)
gentoo auto-resync : 11:06:2024 - 00:08:04
Diffstat (limited to 'media-gfx/cropgui')
-rw-r--r--media-gfx/cropgui/Manifest2
-rw-r--r--media-gfx/cropgui/cropgui-0.8.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/cropgui/Manifest b/media-gfx/cropgui/Manifest
index 4b532cc5f869..e2e1d7ccca60 100644
--- a/media-gfx/cropgui/Manifest
+++ b/media-gfx/cropgui/Manifest
@@ -1,3 +1,5 @@
DIST cropgui-0.7.tar.gz 855705 BLAKE2B d2693034b3e3a4355f58c4d17d355721189da8442b5d49ba4c11dc0033371c74301a99c001613c427375bdb9cd733f56a870186a6a59b631feaae93dbd69b232 SHA512 ea06527bdd80382bf4986ea1eea8d3c0e11ea60c472bebb489fdc3bd8206f087d0377d769e8fe86ec4573f6d510266443fd25134894b91206e1c5c9d6f7cf563
+DIST cropgui-0.8.tar.gz 857102 BLAKE2B 0fb1dd24c282e6c5595de97dc2c52d20e7c1200d7092edb8e3173276873c49512088f1fc8deed0c1e3d6b606009fe06f3c38cf98c7dac15dd74ccbdab2d71539 SHA512 911bea2b989ce53afeaf067fe5d718440b0a15c26b9488259569f1a287c8128cb7244bcb0721b15ec3564644a0ba8e9ed2991d275420bf3e3659cb0be2e8622d
EBUILD cropgui-0.7.ebuild 1148 BLAKE2B 49ad93c2abdab01eb9a198916f550a77e8a8d9368cc88f9e65902c1ce1ca57fa1fa9b420732b56c51ba2f1f772a652b19b70f70e3395ac3f50c0a7086eb6000a SHA512 cfe0ca8e18ba085dd2f0ffbb8555a75e1fbd1c3b81a6a63a742e03dbb0ce2cfb55f8596df1776415ae1513eef9c1ef8e624e2e77cde3812c9a5df21b6439e12e
+EBUILD cropgui-0.8.ebuild 1148 BLAKE2B c6d8c21c7868f9278a74c9c57c83a03eddb8ccf1a5f709e4355f664865054ed2513730f330e6a540d1cba6f3764ae1e4d0621b70eb6d182c22b8438df1383428 SHA512 0788661bfe89640b70f22969fa80ba15dcb1b35772c592d05941881fdd6b4f0c51eeed54fcba782b9191afce3750b87797ac896c94a8605bb91856a6275423d5
MISC metadata.xml 323 BLAKE2B 4f4655c7441d04e7d3840d96e9230c3f479955d01b44344b2b424af910b48e60fdf33a21c5ba6cc5490255a38bcb7f6359516e41ac5569446c7e000e23dda693 SHA512 b40805e072a6f3588784f689fcf6c90525f1b9c23c20570ecc5e647e6d151ab3fd81b953a0263a3c0429947cfca5ef23f2a48a242ee9aa789e2c543ca29eaf86
diff --git a/media-gfx/cropgui/cropgui-0.8.ebuild b/media-gfx/cropgui/cropgui-0.8.ebuild
new file mode 100644
index 000000000000..b089224257bf
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+inherit python-r1 desktop wrapper xdg-utils
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="https://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/exiftool
+ media-gfx/imagemagick"
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ python_moduleinto "${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}