summaryrefslogtreecommitdiff
path: root/media-gfx/cropgui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
commit171d09fa1f429aa43835c618a2c21753ad5209a4 (patch)
tree7a9f3e0ed5e5a7dbabf98c971e8202b7ce50035b /media-gfx/cropgui
parent1826a30af36ae674cb71400eacaf0a0762df510f (diff)
gentoo auto-resync : 21:02:2023 - 14:24:25
Diffstat (limited to 'media-gfx/cropgui')
-rw-r--r--media-gfx/cropgui/Manifest1
-rw-r--r--media-gfx/cropgui/cropgui-0.6-r2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/cropgui/Manifest b/media-gfx/cropgui/Manifest
index ea1397e4f7fe..1be7114f57d9 100644
--- a/media-gfx/cropgui/Manifest
+++ b/media-gfx/cropgui/Manifest
@@ -1,3 +1,4 @@
DIST cropgui-0.6.tar.gz 855329 BLAKE2B d54098cdf8d8a0eb863ba7cf13d798db8102e147c30d64d246fc9955c4ee5aead253273fd66f0f2cd2d5aaf7abd10cfed01936c08daccdd92e342a56923bd95b SHA512 dff9b1ea832c657c4407aea7ddeac880faaa4647bfe51ed43f9c1658f848cf9b6f9608451dcc006fe735012b52d318ebe5b59a31dc293cfabfb5ec5772612b68
EBUILD cropgui-0.6-r1.ebuild 1098 BLAKE2B 88e19527e6fc29635940ee50e2dcfb43cddbdd03b61e4c07ea1edb8b22a8e961a36ad8b9ab35f84b1778a879eae54a3d698c9277a4418f5e51f1e95f6c8df278 SHA512 576e68e0c281ebdf0f675bc693300a867a62425c2b3f205392322e302214609d722227b6836cbb914c4780e557257c0a0bd9def9b59db3e474fceab214151be7
+EBUILD cropgui-0.6-r2.ebuild 1101 BLAKE2B 562b5673c5b45d579ffad5945fdc46a1bdb66237a7c1e7d0f18796de1eaa92f797dd0561e4b9fb16afeb05774a2d03eb58bccfed44d5aef09761bfd37217176b SHA512 9c1dcd99a9c38d5ef8cccf39a6bddbe22d437b3a4c27fe7ac0c7ba1071582bcf5d2f3129807c3d6881b31062c845f7ee7d316e9fb76af924c225263e1a89c0bb
MISC metadata.xml 323 BLAKE2B 4f4655c7441d04e7d3840d96e9230c3f479955d01b44344b2b424af910b48e60fdf33a21c5ba6cc5490255a38bcb7f6359516e41ac5569446c7e000e23dda693 SHA512 b40805e072a6f3588784f689fcf6c90525f1b9c23c20570ecc5e647e6d151ab3fd81b953a0263a3c0429947cfca5ef23f2a48a242ee9aa789e2c543ca29eaf86
diff --git a/media-gfx/cropgui/cropgui-0.6-r2.ebuild b/media-gfx/cropgui/cropgui-0.6-r2.ebuild
new file mode 100644
index 000000000000..8526868539b5
--- /dev/null
+++ b/media-gfx/cropgui/cropgui-0.6-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+inherit python-r1 desktop wrapper xdg-utils
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="https://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+install_cropgui_wrapper() {
+ python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+ make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+ python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
+ rm "${ED}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+ python_moduleinto "${PN}"
+ python_foreach_impl install_cropgui_wrapper
+
+ domenu "${PN}.desktop"
+ doicon "${PN}.png"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}