summaryrefslogtreecommitdiff
path: root/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-21 06:39:12 +0000
commit0464b87d8be9fcf33aebbd906bc0d3a65c953cff (patch)
tree839aded9715eb71cd86edef0ea2a003400b6a63e /media-gfx/cairosvg/cairosvg-2.7.0.ebuild
parentd39430b96ad12b39a0ce35745f3d45d980d1b328 (diff)
gentoo auto-resync : 21:03:2023 - 06:39:12
Diffstat (limited to 'media-gfx/cairosvg/cairosvg-2.7.0.ebuild')
-rw-r--r--media-gfx/cairosvg/cairosvg-2.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/cairosvg-2.7.0.ebuild b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
new file mode 100644
index 000000000000..eca08d075044
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="CairoSVG"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="
+ https://cairosvg.org/
+ https://github.com/Kozea/CairoSVG/
+ https://pypi.org/project/CairoSVG/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # this test compares output against old version; this makes little
+ # sense for us and requires both distfiles around
+ test_non_regression
+)