summaryrefslogtreecommitdiff
path: root/media-gfx/cairosvg/cairosvg-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/cairosvg/cairosvg-2.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/cairosvg/cairosvg-2.0.3.ebuild')
-rw-r--r--media-gfx/cairosvg/cairosvg-2.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/cairosvg-2.0.3.ebuild b/media-gfx/cairosvg/cairosvg-2.0.3.ebuild
new file mode 100644
index 000000000000..8931a2878267
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="http://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( NEWS.rst README.rst TODO.rst )