summaryrefslogtreecommitdiff
path: root/media-gfx/arss/arss-0.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-06 07:06:03 +0000
commitaeb00d494a88844a67a5483be221169c5cc2c4be (patch)
tree31cadd24d79954c602995af6abb621e764729674 /media-gfx/arss/arss-0.2.3-r1.ebuild
parent1c646fe0f6db3b97a61ac9d93f96c0eee5ef517a (diff)
gentoo auto-resync : 06:03:2024 - 07:06:02
Diffstat (limited to 'media-gfx/arss/arss-0.2.3-r1.ebuild')
-rw-r--r--media-gfx/arss/arss-0.2.3-r1.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/media-gfx/arss/arss-0.2.3-r1.ebuild b/media-gfx/arss/arss-0.2.3-r1.ebuild
index a194c54b448f..04680a5ffea3 100644
--- a/media-gfx/arss/arss-0.2.3-r1.ebuild
+++ b/media-gfx/arss/arss-0.2.3-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_IN_SOURCE_BUILD="true"
MY_P="${P}-src"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Analysis & Resynthesis Sound Spectrograph"
HOMEPAGE="https://arss.sourceforge.net"
@@ -22,3 +22,15 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
DOCS=( ../AUTHORS ../ChangeLog )
+
+src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/859604
+ # Upstream is on sourceforge, inactive since 2009. No bug filed.
+ #
+ # Do not trust it for LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}