summaryrefslogtreecommitdiff
path: root/media-gfx/apngasm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/apngasm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/apngasm/files')
-rw-r--r--media-gfx/apngasm/files/apngasm-2.7-string_h.patch16
-rw-r--r--media-gfx/apngasm/files/apngasm-2.91-makefile.patch22
2 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/apngasm/files/apngasm-2.7-string_h.patch b/media-gfx/apngasm/files/apngasm-2.7-string_h.patch
new file mode 100644
index 000000000000..303e832b37c5
--- /dev/null
+++ b/media-gfx/apngasm/files/apngasm-2.7-string_h.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/465780
+
+Same for all of memcpy(), memset(), strlen() and strcpy():
+
+apngasm.c:141:11: warning: incompatible implicit declaration of built-in function ‘memcpy’ [enabled by default]
+
+--- apngasm.c
++++ apngasm.c
+@@ -29,6 +29,7 @@
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "png.h" /* original (unpatched) libpng is ok */
+ #include "zlib.h"
+
diff --git a/media-gfx/apngasm/files/apngasm-2.91-makefile.patch b/media-gfx/apngasm/files/apngasm-2.91-makefile.patch
new file mode 100644
index 000000000000..b9fb9c20ee89
--- /dev/null
+++ b/media-gfx/apngasm/files/apngasm-2.91-makefile.patch
@@ -0,0 +1,22 @@
+--- apngasm-2.91-src/Makefile
++++ apngasm-2.91-src/Makefile
+@@ -1,8 +1,7 @@
+ PACKAGE = apngasm
+ CC = gcc
+-SRC_DIRS = . 7z zopfli
+-CFLAGS = -Wall -pedantic -DFEATURE_7ZIP -DFEATURE_ZOPFLI
+-CFLAGS_OPT = -O2
++SRC_DIRS = . 7z
++CFLAGS += -Wall -pedantic
+ CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
+ LIBS = -lstdc++ -lm -lpng -lz
+
+@@ -16,7 +15,7 @@
+ all : $(PACKAGE)
+
+ $(PACKAGE) : objdirs $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) -s $(LIBS)
++ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) $(LIBS)
+
+ objdirs :
+ mkdir -p $(OBJ_DIRS)