summaryrefslogtreecommitdiff
path: root/media-gfx/apngasm/apngasm-2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/apngasm/apngasm-2.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/apngasm/apngasm-2.7.ebuild')
-rw-r--r--media-gfx/apngasm/apngasm-2.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/apngasm/apngasm-2.7.ebuild b/media-gfx/apngasm/apngasm-2.7.ebuild
new file mode 100644
index 000000000000..49660f693fc4
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="https://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0=[apng]
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-string_h.patch #465780
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}