summaryrefslogtreecommitdiff
path: root/media-gfx/ansilove/ansilove-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /media-gfx/ansilove/ansilove-9999.ebuild
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'media-gfx/ansilove/ansilove-9999.ebuild')
-rw-r--r--media-gfx/ansilove/ansilove-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/media-gfx/ansilove/ansilove-9999.ebuild b/media-gfx/ansilove/ansilove-9999.ebuild
index e593f48c0fb9..d0d4327ea128 100644
--- a/media-gfx/ansilove/ansilove-9999.ebuild
+++ b/media-gfx/ansilove/ansilove-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,13 +6,15 @@ EAPI=8
inherit cmake
DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
-HOMEPAGE="https://github.com/ansilove/ansilove/"
+HOMEPAGE="https://www.ansilove.org/
+ https://github.com/ansilove/ansilove/"
-if [[ "${PV}" == *9999* ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
- SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
@@ -23,7 +25,7 @@ RDEPEND="dev-libs/libansilove"
DEPEND="${RDEPEND}"
src_configure() {
- local mycmakeargs=(
+ local -a mycmakeargs=(
-DENABLE_SECCOMP=NO
)
cmake_src_configure