summaryrefslogtreecommitdiff
path: root/media-gfx/ansilove/ansilove-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-gfx/ansilove/ansilove-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-gfx/ansilove/ansilove-9999.ebuild')
-rw-r--r--media-gfx/ansilove/ansilove-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/ansilove/ansilove-9999.ebuild b/media-gfx/ansilove/ansilove-9999.ebuild
new file mode 100644
index 000000000000..747102f7845f
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://github.com/ansilove/ansilove/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}