summaryrefslogtreecommitdiff
path: root/media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-30 03:36:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-30 03:36:21 +0000
commite6a2fd03865862c81d79bd32249728f20ce99354 (patch)
treee2ba9ebe3405d7f7b4fb3528818e50ff0097a24c /media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild
parent6769d991d1a040381ab263b2eef043e6f50190a6 (diff)
gentoo auto-resync : 30:10:2023 - 03:36:20
Diffstat (limited to 'media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild')
-rw-r--r--media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild b/media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild
new file mode 100644
index 000000000000..7f231de9122d
--- /dev/null
+++ b/media-gfx/ahoviewer/ahoviewer-2.0.0_pre20220827-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+MY_COMMIT="42e16f94b78496e3e346f0d127baa569039a6757"
+
+DESCRIPTION="A GTK image viewer, manga reader, and booru browser"
+HOMEPAGE="https://github.com/ahodesuka/ahoviewer"
+SRC_URI="https://github.com/ahodesuka/ahoviewer/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="keyring gnutls +gstreamer plugins +rar +ssl +zip"
+
+COMMON_DEPEND="dev-cpp/atkmm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/glib:2
+ dev-libs/libconfig:=[cxx]
+ dev-libs/libsigc++:2
+ dev-libs/libxml2:2
+ media-libs/libnsgif
+ net-misc/curl
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ keyring? ( app-crypt/libsecret )
+ gstreamer? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gstreamer:1.0
+ )
+ plugins? (
+ dev-libs/gobject-introspection
+ dev-libs/libpeas:0
+ )
+ rar? ( app-arch/unrar:= )
+ ssl? (
+ gnutls? (
+ dev-libs/libgcrypt:=
+ net-libs/gnutls:=
+ net-misc/curl[curl_ssl_gnutls]
+ )
+ !gnutls? (
+ dev-libs/openssl:=
+ net-misc/curl[curl_ssl_openssl]
+ )
+ )
+ zip? ( dev-libs/libzip:= )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? (
+ media-libs/gst-plugins-base:1.0[X]
+ media-libs/gst-plugins-good:1.0
+ || (
+ media-plugins/gst-plugins-vpx
+ media-plugins/gst-plugins-libav
+ )
+ )"
+
+# In future (-beta), pull https://github.com/ahodesuka/ahoviewer-plugins
+# directly via SRC_URI="plugins? ( )", or add as a separate package. It
+# depends on how the plugins are handled.
+#PDEPEND="plugins? ( x11-misc/ahoviewer-plugins )"
+
+S="${WORKDIR}/ahoviewer-${MY_COMMIT}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature keyring libsecret)
+ $(meson_feature gstreamer)
+ $(meson_feature plugins libpeas)
+ $(meson_feature rar libunrar)
+ $(meson_feature zip libzip)
+ )
+
+ meson_src_configure
+}