summaryrefslogtreecommitdiff
path: root/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 11:36:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 11:36:18 +0100
commit6e88bac8dd26372eea042112ad3769b1fac9ae18 (patch)
treee8694d56fbae41e2d5f4025730db56041463d94e /media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
parentc59fc2181f7402f8d0a548bcc897584a83139cc1 (diff)
gentoo auto-resync : 07:05:2023 - 11:36:18
Diffstat (limited to 'media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild')
-rw-r--r--media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild b/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
new file mode 100644
index 000000000000..bd64d259240f
--- /dev/null
+++ b/media-gfx/aaphoto/aaphoto-0.45_p20160710.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+GIT_COMMIT="ad4fc3c04b9e25212d78c231e1507458dfea8909"
+
+DESCRIPTION="Automatic color correction and resizing of photos"
+HOMEPAGE="https://web.archive.org/web/20220728233436/http://log69.com/aaphoto_en.html https://github.com/log69/aaphoto"
+SRC_URI="https://github.com/log69/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}