summaryrefslogtreecommitdiff
path: root/media-fonts/noto/noto-20240531.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
commit6657c680376cedf378fcf328e5fa03ed3b41d580 (patch)
tree44ea8d174f647daca562b9bdcbcb527a85a77d0a /media-fonts/noto/noto-20240531.ebuild
parent1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (diff)
gentoo auto-resync : 02:06:2024 - 00:07:23
Diffstat (limited to 'media-fonts/noto/noto-20240531.ebuild')
-rw-r--r--media-fonts/noto/noto-20240531.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20240531.ebuild b/media-fonts/noto/noto-20240531.ebuild
new file mode 100644
index 000000000000..8f791f0247e2
--- /dev/null
+++ b/media-fonts/noto/noto-20240531.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://fonts.google.com/noto https://github.com/notofonts/notofonts.github.io"
+
+COMMIT="afdb0f94aa8ea1629948caab32845aade6dc97d2"
+SRC_URI="https://github.com/notofonts/notofonts.github.io/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://fonts.google.com/noto
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/notofonts.github.io-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-hinted || die
+ mv fonts/*/hinted/ttf/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.tt[f,c]
+}