summaryrefslogtreecommitdiff
path: root/media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild')
-rw-r--r--media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild b/media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild
new file mode 100644
index 000000000000..2bbb119adc45
--- /dev/null
+++ b/media-fonts/kochi-substitute/kochi-substitute-20030809-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit font
+
+DESCRIPTION="Kochi Japanese TrueType fonts with Wadalab Fonts"
+HOMEPAGE="http://efont.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/efont/5411/${P}.tar.bz2"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${PV:0:8}
+
+FONT_SUFFIX="ttf"
+
+DOCS="README.ja Changelog docs/README"
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+src_install() {
+ font_src_install
+
+ cd docs
+ local d
+ for d in kappa20 k14goth ayu20gothic wadalab shinonome* naga10; do
+ docinto $d
+ dodoc $d/*
+ done
+}