summaryrefslogtreecommitdiff
path: root/mate-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /mate-extra
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/Manifest.gzbin2900 -> 2908 bytes
-rw-r--r--mate-extra/mate-indicator-applet/Manifest3
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild36
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0.ebuild7
4 files changed, 44 insertions, 2 deletions
diff --git a/mate-extra/Manifest.gz b/mate-extra/Manifest.gz
index ec077543296c..c09e39664112 100644
--- a/mate-extra/Manifest.gz
+++ b/mate-extra/Manifest.gz
Binary files differ
diff --git a/mate-extra/mate-indicator-applet/Manifest b/mate-extra/mate-indicator-applet/Manifest
index d368f1d6c8de..59465c2b4511 100644
--- a/mate-extra/mate-indicator-applet/Manifest
+++ b/mate-extra/mate-indicator-applet/Manifest
@@ -1,3 +1,4 @@
DIST mate-indicator-applet-1.26.0.tar.xz 383936 BLAKE2B 4435c8e2c4acf5cd033a9f85b39a2f577d9861124fa47e22bdba970fb61c9ce5fe8bf31bc87a47a8a8f82640905c50b316f35f572a2a4a83830c8f8d110b80fd SHA512 677586b4090edd22871eb034b923795a01030a5270e633a11ed711171e49f487047fbf75daf1d69d491660bdf63421b900e06fd806eeef93df101058c0130c06
-EBUILD mate-indicator-applet-1.26.0.ebuild 528 BLAKE2B aec0668f17b41e0f3bea9725539bda2cc0d4d3d17b8135e6c145516973fc1ce9b63de24b7a735357594dca70eeadeb86d93c52b7ffa2bc3efe4f2199b95c2348 SHA512 2068365ea85a0e0f8443e6e64612d20cf8e72e1fabcfcba0cbdae826f8817c48abf3b860439cd17f2f4d7dfc6e5a0862740104652c3dadf74b050bd32dcc6023
+EBUILD mate-indicator-applet-1.26.0-r1.ebuild 603 BLAKE2B fbb7878b316737a6c792b709e738197f34e45ce7d58d4a8b6806f473e2771891943fb0c012856a384686b3de33ad03d89bdd5d2c2ca919182b405df148911eb9 SHA512 c70c6430c6b30ad68b689c034b94a5340d91cb3254c54e925010865b50ff429cdd2bcb0473d3b0e9edc7aef1ed116296b69293c9112cbf715af9d3c46ef8fb9a
+EBUILD mate-indicator-applet-1.26.0.ebuild 598 BLAKE2B 9259bc8c3075e17a05375c90f824c9c8c5c3e57a17cc0b360620271e804f8fc9be738d9f506f1e06886b643fdc9e0ab9c562b375660977955d2457ded1a5f19a SHA512 4e89730425d342f61c683f7e276407dbbe4868e077016730479f01f15ddb15b5bfc51e57ab675d3fa529589abab87f76a6edb12112367f41b57a8fcb2400e024
MISC metadata.xml 351 BLAKE2B e48e460d9a4129eb19a7edb5659e7ca8b3bdb62fe6b00e3366be15716c6283ade2707b5a1d03fa9be44cc95ee506a15ff267c7b3e764f71e9f67ba3ca1f4c98a SHA512 2538efec96a0fe9ffb744536b92ccaf5da779efc46a0731849ccbf11348a590d2ecfbf3abc55ba9063ffb96eeca7ecb379927e192371cae681d56dee170a9870
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..95ffd6971d79
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE indicator applet"
+LICENSE="GPL-3 GPL-3+ LGPL-2+ LGPL-3+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/libayatana-indicator:3
+ >=mate-base/mate-panel-1.17.0
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --with-ayatana-indicators
+}
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0.ebuild
index 9313f05140f6..bdcf9fbb50de 100644
--- a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0.ebuild
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.26.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,3 +29,8 @@ BDEPEND="${COMMON_DEPEND}
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+
+src_configure() {
+ mate_src_configure \
+ --with-ubuntu-indicators
+}