summaryrefslogtreecommitdiff
path: root/mate-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
commit12de738b83927a4b71c3ad067edbb6279d15b368 (patch)
tree87b2ef3927262a0aba7a923512909bdbadd71b8b /mate-extra
parent7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (diff)
gentoo auto-resync : 09:05:2023 - 23:42:14
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/Manifest.gzbin2908 -> 2914 bytes
-rw-r--r--mate-extra/mate-sensors-applet/Manifest2
-rw-r--r--mate-extra/mate-sensors-applet/files/1.26.0-clang-16-fix-undeclared-function-setlocale.patch130
-rw-r--r--mate-extra/mate-sensors-applet/mate-sensors-applet-1.26.0-r1.ebuild65
4 files changed, 197 insertions, 0 deletions
diff --git a/mate-extra/Manifest.gz b/mate-extra/Manifest.gz
index 19bd95641481..bfe64273d015 100644
--- a/mate-extra/Manifest.gz
+++ b/mate-extra/Manifest.gz
Binary files differ
diff --git a/mate-extra/mate-sensors-applet/Manifest b/mate-extra/mate-sensors-applet/Manifest
index 83941626ce5b..8bd562ddac5e 100644
--- a/mate-extra/mate-sensors-applet/Manifest
+++ b/mate-extra/mate-sensors-applet/Manifest
@@ -1,3 +1,5 @@
+AUX 1.26.0-clang-16-fix-undeclared-function-setlocale.patch 3154 BLAKE2B 9c1654cede2f09e589ff29e5cbb4e425e30a67ec21149dea896c38c64b09adb6b0aeff973ed1e4b7c4ca5f7f868978f7c9e19eb081dea7fa0a07cb1b1c0043ee SHA512 c7f887d7892a14ff29385e8954e928a329fd3e848f9981093fe3cdda472332caf1ba1ff5ab9afd45f6e9f2c38f496161ada5a8a62e4a7f5e8eae64215d0abf5a
DIST mate-sensors-applet-1.26.0.tar.xz 563440 BLAKE2B 87919c3299253dc037d165dc7223fb7e02f993568ef454211746fffa2e260f54b9ad76bd5b023f9aa215a4796aa2a34dda249b132c415af7c5c4e82e84c5086b SHA512 1419c63e823bcec5d8fc4a619b3eb6c1eef0ac5d923177fae6649664616824cb5a257121aa88ab5d56d1d5ff5c44f1d62a4dd325dc718091e2d2e16ae326fa36
+EBUILD mate-sensors-applet-1.26.0-r1.ebuild 1376 BLAKE2B 416068b69d7ed245a1ac9ec0c63fba9900b604ab9712eb3f029d174f7bb81a2ff526a249c59c1b36bb84908deeec9afed26ce341276252ba8433286810fbd9c3 SHA512 a26d9acdd15f8f00ad98781df9eda22aeb3299618b411559f577a6429bba30253b4bdf29c985b4771d35053d5a5923c342a53967aa6657a3505e8c33eb910c5a
EBUILD mate-sensors-applet-1.26.0.ebuild 1291 BLAKE2B 24637e9cfef8d4c120da6611cd35677dd0f9e23fd87ab37e7c4588facbdd11e5f0e7f40e34069c4e8694da675ca04ecafe4f755e4f8776df8aee2b54960a5496 SHA512 8f5e4674accc6062b32d7ca09268fa2a6a532fb87ef605669a251c86eed02ba51c626f033bc891ed351de909b21dd3219d190758de679a890250d70ba9229a30
MISC metadata.xml 349 BLAKE2B 4576e875f56359cf193615e38e75b15a2f91e3727c1fae0c8c939a56c0ca93cbdba7ac7dbf4dbc8268901c8c62f3d0206a609d7bdbecfd6397f6032fa23f871f SHA512 22b33a8b3faf88d642cd3eebc15421c7b62511da5fdc1171aecc72074400c325ef3d91c2a4d380126c9d71edfc3c68cc48df9f8dae338f97c33389b3069d69c0
diff --git a/mate-extra/mate-sensors-applet/files/1.26.0-clang-16-fix-undeclared-function-setlocale.patch b/mate-extra/mate-sensors-applet/files/1.26.0-clang-16-fix-undeclared-function-setlocale.patch
new file mode 100644
index 000000000000..a0b83dba38b2
--- /dev/null
+++ b/mate-extra/mate-sensors-applet/files/1.26.0-clang-16-fix-undeclared-function-setlocale.patch
@@ -0,0 +1,130 @@
+From 3ff9fb450aa2a28221fcd863bf7913e84eeeb7ba Mon Sep 17 00:00:00 2001
+From: listout <brahmajit.xyz@gmail.com>
+Date: Fri, 5 May 2023 11:07:20 +0530
+Subject: [PATCH] unconditionally include stdio.h and locale.h
+
+On musl mate-sensor-applet fails to build with error message saying
+"LC_NUMERIC undeclared". As suggested in issue mate-desktop#123, removing the include
+guards around #include <local.h> and #include <stdio.h>
+
+Upstream commit: https://patch-diff.githubusercontent.com/raw/mate-desktop/mate-sensors-applet/pull/128.patch
+Bug: https://bugs.gentoo.org/896200
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,7 +38,6 @@ AC_SUBST(LIBS)
+ AC_CHECK_HEADERS(
+ stdlib.h \
+ string.h \
+- stdio.h \
+ sys/types.h \
+ sys/socket.h \
+ netinet/in.h \
+--- a/plugins/acpi/acpi-plugin.c
++++ b/plugins/acpi/acpi-plugin.c
+@@ -21,10 +21,7 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "acpi-plugin.h"
+--- a/plugins/i2c-proc/i2c-proc-plugin.c
++++ b/plugins/i2c-proc/i2c-proc-plugin.c
+@@ -21,14 +21,8 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+-#ifdef HAVE_LOCALE_H
+ #include <locale.h>
+-#endif
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "i2c-proc-plugin.h"
+--- a/plugins/i2c-sys/i2c-sys-plugin.c
++++ b/plugins/i2c-sys/i2c-sys-plugin.c
+@@ -21,10 +21,7 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "i2c-sys-plugin.h"
+--- a/plugins/i8k/i8k-plugin.c
++++ b/plugins/i8k/i8k-plugin.c
+@@ -21,10 +21,7 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "i8k-plugin.h"
+--- a/plugins/ibm-acpi/ibm-acpi-plugin.c
++++ b/plugins/ibm-acpi/ibm-acpi-plugin.c
+@@ -21,10 +21,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "ibm-acpi-plugin.h"
+--- a/plugins/omnibook/omnibook-plugin.c
++++ b/plugins/omnibook/omnibook-plugin.c
+@@ -21,10 +21,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "omnibook-plugin.h"
+--- a/plugins/pmu-sys/pmu-sys-plugin.c
++++ b/plugins/pmu-sys/pmu-sys-plugin.c
+@@ -21,10 +21,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "pmu-sys-plugin.h"
+--- a/plugins/smu-sys/smu-sys-plugin.c
++++ b/plugins/smu-sys/smu-sys-plugin.c
+@@ -21,10 +21,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include "smu-sys-plugin.h"
diff --git a/mate-extra/mate-sensors-applet/mate-sensors-applet-1.26.0-r1.ebuild b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..47853d0d23d7
--- /dev/null
+++ b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.26.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE panel applet to display readings from hardware sensors"
+LICENSE="FDL-1.1+ GPL-2+"
+SLOT="0"
+
+IUSE="+dbus hddtemp libnotify lm-sensors video_cards_nvidia"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=mate-base/mate-panel-1.17.0
+ >=x11-libs/cairo-1.0.4
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ hddtemp? ( >=app-admin/hddtemp-0.3_beta13 )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ lm-sensors? ( sys-apps/lm-sensors )
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:2 ) )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-clang-16-fix-undeclared-function-setlocale.patch
+)
+
+src_configure() {
+ local udisks
+
+ if use hddtemp && use dbus; then
+ udisks="--enable-udisks2"
+ else
+ udisks="--disable-udisks2"
+ fi
+
+ mate_src_configure \
+ --disable-netbsd \
+ $(use_enable libnotify) \
+ $(use_with lm-sensors libsensors) \
+ $(use_with video_cards_nvidia nvidia) \
+ ${udisks}
+}