summaryrefslogtreecommitdiff
path: root/mate-extra/mate-system-monitor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 19:18:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 19:18:10 +0100
commit07b0c0005f55e652101816d9f4cfe73403bf0906 (patch)
treeb29108de370177e8ce7c0d0d60e1e4319851d99b /mate-extra/mate-system-monitor
parent78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (diff)
gentoo auto-resync : 04:10:2022 - 19:18:10
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/Manifest4
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.26.0.ebuild66
-rw-r--r--mate-extra/mate-system-monitor/metadata.xml6
3 files changed, 74 insertions, 2 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index d037c7baba15..836fbdc870e2 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,3 +1,5 @@
DIST mate-system-monitor-1.24.2.tar.xz 2429196 BLAKE2B 03d0555d74ba4ba9a80727fa383ad02515a46f61fd1df3487b7acabef4b0561e03d86082c9c161a533716416bab73fad5bd826329c69d1826eeb7dd73a1b4e41 SHA512 4fd0f1a3dc5611d66b2e1ca35171f2056994332f87d895321c384a696afa359a2b78d2b0c2d698923039549f886976f04b1a8c92c928dfe9e2a1a159540a1895
+DIST mate-system-monitor-1.26.0.tar.xz 2472116 BLAKE2B e9613206444ab59d3612168e72dedee70f7d39f531075609fd2d8a0d9c94a7150e0862fd635393739f78e3fb3384e5febeda5a64f4d7dc13ba3e2e2909169dbf SHA512 90919af4808348f6d6a66a4dddb02f2b9d2dc2ee42100b28baa104a504b0b0a6d488814381a657d682b3f53e0a5cdf99fc0a6142eab86d77ca1d5147da526c58
EBUILD mate-system-monitor-1.24.2.ebuild 1302 BLAKE2B 430e489806adb26fe5fa622ad0a7968d166f87208383c05f4ac8fefe8bdf111263387a2d7fd92fd9b0d01ac630ea3c482159cba78c086e51f892889f388fa6e2 SHA512 a040816297148452a08de6cfb5b138fbb469ef5f1521bf5b33134612cac0a0fc0942e78a54f0e802a399b1ab1a0a9c19516d71d0f5323e6ef2c2d888ec34a3c4
-MISC metadata.xml 349 BLAKE2B 87151a68740d4e98e16966fa07d9ddf1b2b7a7552b40971240a1ff6d4981c1a61c8c5c6388e9f945956139e1f0b9ab6c5726bdb1b4ce2ea2bd0f6c85966fc57b SHA512 5194451bc7d3241e44eda4cfc2a7bbf80d6896483bdad1132897e87bfc19167dc278294c03ce5fcd23c53082ae8f13ba45d0d16d29f90b2349206119b740d219
+EBUILD mate-system-monitor-1.26.0.ebuild 1332 BLAKE2B 3d18d36f155f229bee767235d381b432b9523230c5d294ba7736dc79b40b3dea48fa0853129d1a1d9455a1cf4600c6340a5598f497367e2f404b93ab16322eef SHA512 241c3df1a7b28a919526fe91f783a63dd4196d13b623859315925e5c29110d5060806580735e03dd1cf24b99b0f83f7f32cc9cd512b85cc44064be837dd4d782
+MISC metadata.xml 456 BLAKE2B 5fb21adcfa1df0228a2ee838de4f8397a7a8b12baedfafdd8e3fa0f082d5ed161036b2f0947a5b9c47b834dc6778cce3bb69d2e1512a7be8cf0de46aaee465d9 SHA512 de62b694e19f930152c20677ad94bb1ab433a65898a55ab57afffddb37110dcc8ffc07e7113fc049c595977bfd2e533acbcac8ccef872f207026b2634f4c4643
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.26.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.26.0.ebuild
new file mode 100644
index 000000000000..841c6739699d
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.26.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mate toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd wnck"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+ myconf+=(
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}" \
+ $(use_enable wnck)
+}
diff --git a/mate-extra/mate-system-monitor/metadata.xml b/mate-extra/mate-system-monitor/metadata.xml
index f88ea65955cd..46ca0b2041f0 100644
--- a/mate-extra/mate-system-monitor/metadata.xml
+++ b/mate-extra/mate-system-monitor/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>mate@gentoo.org</email>
@@ -8,4 +8,8 @@
<upstream>
<remote-id type="github">mate-desktop/mate-system-monitor</remote-id>
</upstream>
+ <use>
+ <flag name="wnck">Enable experimental support
+ using <pkg>x11-libs/libwnck</pkg>.</flag>
+ </use>
</pkgmetadata>