summaryrefslogtreecommitdiff
path: root/mate-extra/caja-hide/caja-hide-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /mate-extra/caja-hide/caja-hide-0.9.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'mate-extra/caja-hide/caja-hide-0.9.0.ebuild')
-rw-r--r--mate-extra/caja-hide/caja-hide-0.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mate-extra/caja-hide/caja-hide-0.9.0.ebuild b/mate-extra/caja-hide/caja-hide-0.9.0.ebuild
new file mode 100644
index 000000000000..029a1ed15148
--- /dev/null
+++ b/mate-extra/caja-hide/caja-hide-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+inherit python-single-r1
+
+MY_PN="Caja-hide"
+
+DESCRIPTION="Hide files without renaming them in MATE's Caja"
+HOMEPAGE="https://github.com/Fred-Barclay/Caja-hide"
+SRC_URI="https://github.com/Fred-Barclay/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep 'dev-python/future[${PYTHON_MULTI_USEDEP}]')
+ dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
+ x11-misc/xautomation
+"
+BDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3-support.patch"
+)
+
+src_install() {
+ insinto /usr/share/caja-python/extensions
+ doins src/caja-hide.py
+}