summaryrefslogtreecommitdiff
path: root/mate-base/mate-applets/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /mate-base/mate-applets/files
reinit the tree, so we can have metadata
Diffstat (limited to 'mate-base/mate-applets/files')
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch46
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch44
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.14.1-revert-upstream-cpupower-4.7-fix.patch37
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch44
4 files changed, 171 insertions, 0 deletions
diff --git a/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch
new file mode 100644
index 000000000000..070b41754ed0
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.10.4-cpupower-4.7.patch
@@ -0,0 +1,46 @@
+diff --git a/configure.ac b/configure.ac
+index c867af3..4ff5311 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -416,6 +416,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 40c44ba..120693c 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,11 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+@@ -111,7 +114,11 @@ cpufreq_monitor_libcpufreq_run (CPUFreqMonitor *monitor)
+ /* Check whether it failed because
+ * cpu is not online.
+ */
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
++#else
++ if (cpupower_is_cpu_online (cpu)) {
++#endif
+ g_object_set (G_OBJECT (monitor), "online", FALSE, NULL);
+ return TRUE;
+ }
diff --git a/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch
new file mode 100644
index 000000000000..203f1589a1b2
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.14.1-cpupower-4.7.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index b49d127..6b87389 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -411,6 +411,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 4fa9d4c..ba52fde 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,12 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+@@ -112,7 +116,7 @@
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
+ #else
+ if (cpupower_is_cpu_online (cpu)) {
diff --git a/mate-base/mate-applets/files/mate-applets-1.14.1-revert-upstream-cpupower-4.7-fix.patch b/mate-base/mate-applets/files/mate-applets-1.14.1-revert-upstream-cpupower-4.7-fix.patch
new file mode 100644
index 000000000000..85c2b24bc81b
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.14.1-revert-upstream-cpupower-4.7-fix.patch
@@ -0,0 +1,37 @@
+From e82b68edbfa8d6e209b9ad7b3e6392a928da776e Mon Sep 17 00:00:00 2001
+From: mudler <mudler@sabayon.org>
+Date: Tue, 13 Sep 2016 23:33:58 +0200
+Subject: [PATCH] fix 1.14.1 on kernel-headers >=4.7
+
+---
+ cpufreq/src/cpufreq-monitor-libcpufreq.c | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 228a890..587e316 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -23,7 +23,7 @@
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
++
+ #include <cpufreq.h>
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+@@ -111,11 +111,7 @@ cpufreq_monitor_libcpufreq_run (CPUFreqMonitor *monitor)
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
+ if (!cpufreq_cpu_exists (cpu)) {
+-#else
+- if (cpupower_is_cpu_online (cpu)) {
+-#endif
+ g_object_set (G_OBJECT (monitor), "online", FALSE, NULL);
+ return TRUE;
+ }
+--
+2.9.2
+
diff --git a/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
new file mode 100644
index 000000000000..3f4f4fa519f1
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.16.0-cpupower-4.7.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index b49d127..6b87389 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -411,6 +411,8 @@ fi
+ AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+ AC_SUBST(LIBCPUFREQ_LIBS)
+
++AC_CHECK_HEADERS([cpupower.h])
++
+ build_cpufreq_applet=no
+
+ if test x$disable_cpufreq = xno; then
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 4fa9d4c..ba52fde 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -19,12 +19,16 @@
+ * Authors : Carlos García Campos <carlosgc@gnome.org>
+ */
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
+-#include <linux/version.h>
+ #include <cpufreq.h>
++#ifdef HAVE_CPUPOWER_H
++#include <cpupower.h>
++#endif
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+
+@@ -111,7 +115,7 @@
+ /* Check whether it failed because
+ * cpu is not online.
+ */
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
++#ifndef HAVE_CPUPOWER_H
+ if (!cpufreq_cpu_exists (cpu)) {
+ #else
+ if (cpupower_is_cpu_online (cpu)) {