summaryrefslogtreecommitdiff
path: root/mail-mta/esmtp/esmtp-1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /mail-mta/esmtp/esmtp-1.2-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'mail-mta/esmtp/esmtp-1.2-r2.ebuild')
-rw-r--r--mail-mta/esmtp/esmtp-1.2-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail-mta/esmtp/esmtp-1.2-r2.ebuild b/mail-mta/esmtp/esmtp-1.2-r2.ebuild
new file mode 100644
index 000000000000..af0fec0f53e2
--- /dev/null
+++ b/mail-mta/esmtp/esmtp-1.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="User configurable relay-only Mail Transfer Agent with a sendmail-like syntax"
+HOMEPAGE="http://esmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ >=net-libs/libesmtp-1.0.6_p20200824:=
+ !mail-mta/courier
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp
+ !mail-mta/opensmtpd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2-pkgconfig.patch" )
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO sample.esmtprc )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "A sample esmtprc file has been installed in /usr/share/doc/${PF}"
+}