summaryrefslogtreecommitdiff
path: root/mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild')
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild b/mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild
new file mode 100644
index 000000000000..6ea964ca31e1
--- /dev/null
+++ b/mail-filter/spamprobe/spamprobe-1.4d-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis"
+HOMEPAGE="http://spamprobe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="berkdb gif jpeg png"
+
+RDEPEND="
+ berkdb? ( >=sys-libs/db-3.2:* )
+ gif? ( media-libs/giflib:= )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4b-gcc43.patch
+ "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}+db-5.0.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-giflib5.patch
+)
+
+src_configure() {
+ econf \
+ $(use_with gif) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_install() {
+ default
+ insinto /usr/share/${PN}/contrib
+ doins contrib/*
+}