summaryrefslogtreecommitdiff
path: root/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild')
-rw-r--r--mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild b/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
new file mode 100644
index 000000000000..b7766b0cbbe6
--- /dev/null
+++ b/mail-filter/pyzor/pyzor-1.0.0_p20211223.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_COMMIT="2dbe627c1ec245db206cdc73bf1f9d785f1512d8"
+DESCRIPTION="A distributed, collaborative spam detection and filtering network"
+HOMEPAGE="https://github.com/SpamExperts/pyzor"
+SRC_URI="https://github.com/SpamExperts/pyzor/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gdbm gevent mysql pyzord redis test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ pyzord? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ gevent? ( dev-python/gevent[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ )"
+DEPEND="
+ test? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
+ )
+"
+
+# TODO: maybe upstream would support skipping tests for which the
+# dependencies are missing?
+REQUIRED_USE="
+ pyzord? ( || ( gdbm redis ) )
+ test? ( gdbm redis )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv tests/unit || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use pyzord; then
+ dodir /usr/sbin
+ mv "${ED}"/usr/bin/pyzord* "${ED}/usr/sbin" \
+ || die "failed to relocate pyzord"
+ else
+ rm "${ED}"/usr/bin/pyzord* || die "failed to remove pyzord"
+ fi
+}