summaryrefslogtreecommitdiff
path: root/mail-filter/opendmarc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /mail-filter/opendmarc
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'mail-filter/opendmarc')
-rw-r--r--mail-filter/opendmarc/Manifest2
-rw-r--r--mail-filter/opendmarc/opendmarc-1.4.1.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/mail-filter/opendmarc/Manifest b/mail-filter/opendmarc/Manifest
index 9054da571d6d..fba7d6ea09a2 100644
--- a/mail-filter/opendmarc/Manifest
+++ b/mail-filter/opendmarc/Manifest
@@ -4,5 +4,7 @@ AUX opendmarc.confd 85 BLAKE2B 52cccfd8d194febc24453ad92bebf4358f92125cc4512e664
AUX opendmarc.initd 1509 BLAKE2B b1cde9546c95b51c8c395f10eddf85bcb2fd17fd8a537df523e04a71d241c0fad4a3d2e4c34c950d7b684be518368fe78538828b81627d647e3531177eabb85e SHA512 00c9901cf5b460e20d8010d4aedfd7c338c76d1053f9ddcd9d4aa2c183345e3b810d0bee1207ff9a7ad988577192c52470ca62c67130a981fa67e393d5c70129
AUX opendmarc.service 800 BLAKE2B 866b1aaa0c8570494ac56aaa9962821204a7a24437cdb8bec0343c716cfc1d3748a368a32ec314dfce7e4264188cfb1dff51212d60340d4be8e33394a85486f6 SHA512 b140dc3ac99ee7c3dcee80743d6c4295dec4ce5090ab9f560ffe35f9d5e63c7f5af871edcc759be462b8110706028c047cd05ae910a74ecba0436620d6b291bb
DIST opendmarc-1.3.3.tar.gz 575319 BLAKE2B 72dae5553fea9a51d860aaac6d85171a245584a74134df2249217a88f3da04c4eb518141f6342e281c6a9186345d69a34b585dc3ed18bdb53313374db505f4f5 SHA512 bb4bf8e3ad2d1732b07e55316819d4fd708e529b54a336d7d00763e13bfc62580bb1b30f132fa786dbca15e526e8dd5e146c7be454e1c42714a9f57126fc5e12
+DIST opendmarc-1.4.1.1.tar.gz 426618 BLAKE2B a74b2623bc35abb5c34f8d1eff737c71af8f5cadfd6a5d0a85adb6536efd2958118f9da25dd9b736dc24563221968c4ee1ff99b101fa30909764563bda2a8d88 SHA512 ee034386c70c75b87ca2fce0849a1a3538e10e0aebfb0fc9dcba6817d2cf71f52aa5586ccaacdee620190c5fbb81498419fb8e8db9fac15d7c71a61a7da396a6
EBUILD opendmarc-1.3.3.ebuild 1886 BLAKE2B d94da2b2c301f7b208dd43272539ee93758ff01b6ac583f9f6a092a8582492c6a5edb57a305380b5169a76e9c7ba5d32d8945535590406f1bd8d6ca90f745f57 SHA512 d8106ffa6ef62c24ad9503a499c8fe9bc1c84320b47a3eb84d59421f3855de70054b7cfc394d66f0260a51aab40bcc40639ec0c8c694503cc62c9b3b0afd14ea
+EBUILD opendmarc-1.4.1.1.ebuild 1628 BLAKE2B 48318219c649ffffe5002f01137bd41c0aac72fd69c4013185db8b1adcda1850a767e08a108073f9b5667954854666a45794c89e4be0471e6fbfabcfa4007c98 SHA512 5209b9da1408086f66c401ae3457f0184de5e07c631042f19c5e035d91f9baada2a8d2878c0afcebc7f2a21a2284d7d5053e2455d4ffda4e3669e51b583bcf95
MISC metadata.xml 512 BLAKE2B e837ed3fdef4432f4a6e208b57942ac6b74de558ad20fa978ce046d49147b4225720506c7191a07eeceeb85d6773d3f6d2ae5ca62c08fddb7126061bcfd46fdb SHA512 33b5347b487959b6412dd8a9e7babf0cedac3dd27eb6397dfc226de5d34b70c7e67e9b30dae231bdf743e4c18ffd2cfcd6df1af450e201cafa3c5105d5a889f0
diff --git a/mail-filter/opendmarc/opendmarc-1.4.1.1.ebuild b/mail-filter/opendmarc/opendmarc-1.4.1.1.ebuild
new file mode 100644
index 000000000000..793fac6ee9b6
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.4.1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib systemd
+
+DESCRIPTION="Open source DMARC implementation"
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="https://github.com/trusteddomainproject/OpenDMARC/archive/rel-${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spf +reports static-libs"
+
+DEPEND="reports? ( dev-perl/DBI )
+ || ( mail-filter/libmilter mail-mta/sendmail )"
+RDEPEND="${DEPEND}
+ acct-user/opendmarc
+ reports? (
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Message
+ dev-perl/Switch
+ )
+ spf? ( mail-filter/libspf2 )"
+
+S=${WORKDIR}/OpenDMARC-rel-${PN}-${PV//./-}
+
+src_prepare() {
+ default
+
+ eautoreconf
+ if use !reports ; then
+ sed -i -e '/^SUBDIRS =/s/reports//' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with spf) \
+ $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
+ $(use_with spf spf2-lib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.la
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's:^# UserID .*$:UserID opendmarc:' \
+ -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
+ -e '/^# Socket /s:^# ::' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}