summaryrefslogtreecommitdiff
path: root/mail-filter/opendmarc/opendmarc-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /mail-filter/opendmarc/opendmarc-1.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'mail-filter/opendmarc/opendmarc-1.3.1.ebuild')
-rw-r--r--mail-filter/opendmarc/opendmarc-1.3.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/mail-filter/opendmarc/opendmarc-1.3.1.ebuild b/mail-filter/opendmarc/opendmarc-1.3.1.ebuild
new file mode 100644
index 000000000000..22347bba5397
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="Open source DMARC implementation "
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="mirror://sourceforge/opendmarc/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~x86 ~x86-fbsd"
+IUSE="spf"
+
+DEPEND="dev-perl/DBI
+ || ( mail-filter/libmilter mail-mta/sendmail )"
+RDEPEND="${DEPEND}
+ dev-perl/Switch
+ spf? ( mail-filter/libspf2 )"
+
+pkg_setup() {
+ enewgroup milter
+ enewuser milter -1 -1 /var/lib/milter milter
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ $(use_with spf)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+
+ dodir /etc/opendmarc
+
+ # create config file
+ sed \
+ -e 's/^# UserID .*$/UserID milter/' \
+ -e 's/^# PidFile .*/PidFile \/var\/run\/opendmarc\/opendmarc.pid/' \
+ -e '/^# Socket /s/^# //' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}