summaryrefslogtreecommitdiff
path: root/mail-client/mailx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /mail-client/mailx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'mail-client/mailx/files')
-rw-r--r--mail-client/mailx/files/mailx-8.1.2.20050715-musl.patch19
-rw-r--r--mail-client/mailx/files/mailx-8.1.2.20050715-nostrip.patch22
-rw-r--r--mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch36
3 files changed, 77 insertions, 0 deletions
diff --git a/mail-client/mailx/files/mailx-8.1.2.20050715-musl.patch b/mail-client/mailx/files/mailx-8.1.2.20050715-musl.patch
new file mode 100644
index 000000000000..a2e03ec9753f
--- /dev/null
+++ b/mail-client/mailx/files/mailx-8.1.2.20050715-musl.patch
@@ -0,0 +1,19 @@
+--- a/mailx-8.1.2-0.20050715cvs.orig/EXT/vis.h
++++ b/mailx-8.1.2-0.20050715cvs.orig/EXT/vis.h
+@@ -70,9 +70,6 @@
+ */
+ #define UNVIS_END 1 /* no more characters */
+
+-#include <sys/cdefs.h>
+-
+-__BEGIN_DECLS
+ char *vis(char *, int, int, int);
+ int strvis(char *, const char *, int);
+ int strnvis(char *, const char *, size_t, int)
+@@ -84,6 +81,4 @@ int unvis(char *, char, int *, int);
+ ssize_t strnunvis(char *, const char *, size_t)
+ /* __attribute__ ((__bounded__(__string__,1,3)))*/;
+
+-__END_DECLS
+-
+ #endif /* !_VIS_H_ */
diff --git a/mail-client/mailx/files/mailx-8.1.2.20050715-nostrip.patch b/mail-client/mailx/files/mailx-8.1.2.20050715-nostrip.patch
new file mode 100644
index 000000000000..14a05ba4d6dc
--- /dev/null
+++ b/mail-client/mailx/files/mailx-8.1.2.20050715-nostrip.patch
@@ -0,0 +1,22 @@
+Index: mailx-8.1.2-0.20050715cvs.orig/Makefile
+===================================================================
+--- mailx-8.1.2-0.20050715cvs.orig.orig/Makefile
++++ mailx-8.1.2-0.20050715cvs.orig/Makefile
+@@ -3,16 +3,7 @@
+ PROG=mail
+ CC=gcc
+
+-CFLAGS=-D_BSD_SOURCE -DDEBIAN -g -Wall -IEXT
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+- LDFLAGS += -s
+-endif
++CFLAGS=-D_BSD_SOURCE -DDEBIAN -g -Wall -IEXT ${EXTRAFLAGS}
+
+ SRCS= version.c aux.c cmd1.c cmd2.c cmd3.c cmdtab.c collect.c \
+ edit.c fio.c getname.c head.c v7.local.c lex.c list.c main.c names.c \
diff --git a/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch b/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch
new file mode 100644
index 000000000000..7af81285d33c
--- /dev/null
+++ b/mail-client/mailx/files/mailx-8.1.2.20050715-offsetof.patch
@@ -0,0 +1,36 @@
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/def.h mailx-8.1.2-0.20050715cvs.orig/def.h
+--- mailx-8.1.2-0.20050715cvs.orig.orig/def.h 2003-10-14 21:50:20.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/def.h 2010-03-31 10:29:37.000000000 +0900
+@@ -97,7 +97,7 @@
+ * Given a file address, determine the block number it represents.
+ */
+ #define blockof(off) ((int) ((off) / 4096))
+-#define offsetof(off) ((int) ((off) % 4096))
++#define offsetofmailx(off) ((int) ((off) % 4096))
+ #define positionof(block, offset) ((off_t)(block) * 4096 + (offset))
+
+ /*
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/edit.c mailx-8.1.2-0.20050715cvs.orig/edit.c
+--- mailx-8.1.2-0.20050715cvs.orig.orig/edit.c 2004-05-25 01:34:32.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/edit.c 2010-03-31 10:41:28.000000000 +0900
+@@ -111,7 +111,7 @@
+ (void)fseek(otf, 0L, 2);
+ size = ftell(otf);
+ mp->m_block = blockof(size);
+- mp->m_offset = offsetof(size);
++ mp->m_offset = offsetofmailx(size);
+ mp->m_size = fsize(fp);
+ mp->m_lines = 0;
+ mp->m_flag |= MODIFY;
+diff -r -u mailx-8.1.2-0.20050715cvs.orig.orig/fio.c mailx-8.1.2-0.20050715cvs.orig/fio.c
+--- mailx-8.1.2-0.20050715cvs.orig.orig/fio.c 2004-05-25 01:34:32.000000000 +0900
++++ mailx-8.1.2-0.20050715cvs.orig/fio.c 2010-03-31 10:29:28.000000000 +0900
+@@ -139,7 +139,7 @@
+ this.m_size = 0;
+ this.m_lines = 0;
+ this.m_block = blockof(offset);
+- this.m_offset = offsetof(offset);
++ this.m_offset = offsetofmailx(offset);
+ inhead = 1;
+ } else if (linebuf[0] == 0) {
+ inhead = 0;