summaryrefslogtreecommitdiff
path: root/mail-client/aerc/aerc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /mail-client/aerc/aerc-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'mail-client/aerc/aerc-9999.ebuild')
-rw-r--r--mail-client/aerc/aerc-9999.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/mail-client/aerc/aerc-9999.ebuild b/mail-client/aerc/aerc-9999.ebuild
index db3a9c7f1487..44c0b5357581 100644
--- a/mail-client/aerc/aerc-9999.ebuild
+++ b/mail-client/aerc/aerc-9999.ebuild
@@ -1,23 +1,18 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-inherit go-module
+EAPI=8
+inherit go-module xdg
DESCRIPTION="Email client for your terminal"
HOMEPAGE="https://aerc-mail.org"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/aerc"
+ EGIT_REPO_URI="https://git.sr.ht/~rjarry/aerc"
else
- EGO_SUM=(
- # to be filled on bumps
- )
- go-module_set_globals
- SRC_URI="https://git.sr.ht/~sircmpwn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_SUM_SRC_URI}"
+ SRC_URI="https://git.sr.ht/~rjarry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.gz"
KEYWORDS="~amd64 ~ppc64"
fi
@@ -25,14 +20,13 @@ LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
IUSE="notmuch"
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
BDEPEND="
>=app-text/scdoc-1.9.7
>=dev-lang/go-1.13
"
-DEPEND="notmuch? ( net-mail/notmuch:= )"
-RDEPEND="${DEPEND}"
-
src_unpack() {
if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
@@ -43,8 +37,9 @@ src_unpack() {
}
src_compile() {
- use notmuch && export GOFLAGS="-tags=notmuch"
- emake PREFIX="${EPREFIX}/usr"
+ LDFLAGS= \
+ emake GOFLAGS="-mod=vendor $(usex notmuch "-tags=notmuch" "")" \
+ PREFIX="${EPREFIX}/usr"VERSION=${PV} all
}
src_install() {
@@ -68,4 +63,5 @@ pkg_postinst() {
elog "need to use them."
fi
done
+ xdg_pkg_postinst
}