summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /lxqt-base/lxqt-admin
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'lxqt-base/lxqt-admin')
-rw-r--r--lxqt-base/lxqt-admin/Manifest2
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index f449c4d4bcf0..3db825c56d7b 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1,3 +1,5 @@
DIST lxqt-admin-0.17.0.tar.xz 145620 BLAKE2B 3f1bc0870ef33a85a14dca559951826c56a2ebe81f6cad53917db87ce38b909aed4daed7964d202715dd4d9c7947b23f2aba0fdcb020b6b418c91d9f12c90573 SHA512 5d807b1bbde586130ab03cecf43dc190cbbed5c16842d14779f67f7b514689e7ea330f6c75916c733e4e840242d7feaceb4b6e0932ece1ca70bff208eb5e8072
+DIST lxqt-admin-1.0.0.tar.xz 148732 BLAKE2B 0d3b654f90bd2573629ebb6c61faec621d3c7f547c7690e071d42bab2c062b495043bfa6c2e1d8107b2d2457635dc02ce6d0323906ae25203a4f84a17f0f0fda SHA512 af1cbdd0e04116ad575b652b4eef0fd0a403b37e169961797cc365fe69e5655c6291205165baab4bb3337506785d70149f2b6175758448bd06800fa6f4eb4617
EBUILD lxqt-admin-0.17.0.ebuild 707 BLAKE2B dfd20849555525459b60c4970733792e4cbb282b01e760df7bf75971c0326b08b075127d6b60d82c29ef4e25053886945ea9ac676566366813108d7a93626e43 SHA512 fe7b3bb937c7f3b77af12f027d479a2eabeaa272c2b08768da2613238be99f83b718cb99a9afcd5d591f0a62ac246b03dd1d7c47f9f1d7d0735e64902ab14a94
+EBUILD lxqt-admin-1.0.0.ebuild 790 BLAKE2B 25cf8c8a6f2d913ebcf0778ab94b0a9b5f975488c89fc8317a1dd884ad960be674ae0e7309f1c9515d60c4891db0ce85d95bc30071647c1186cb05156f086977 SHA512 4f11620240b7ce50d1930932e9049a887ec0e786e644777b7432c54b85e72d6af17811d7b6cfcab1365036883a724e0c1e362c23d1290bc7e8179c55111d98c2
MISC metadata.xml 317 BLAKE2B c32f550919926072fb231380675673979f2fee61297981c2ac55300c395dc9052c3f45328641c63d0c42c8ca5053958b7a984942053c5cd4c56cf6a6a4b67743 SHA512 8b3d716d96e51ebfbc7e153c1e92e76eb01dc9df52ce48673117b8ddc2b5670812d380fc6eac47c73d80f72bf67a9a3e09c91d1f6393c390b1271608c7bfeb2f
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
new file mode 100644
index 000000000000..f459b4980175
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.10.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"