summaryrefslogtreecommitdiff
path: root/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild')
-rw-r--r--lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild b/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..ab03ab7ac90f
--- /dev/null
+++ b/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LXAppearance plugin for configuring OpenBox"
+HOMEPAGE="https://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ gnome-base/librsvg:2
+ >=lxde-base/lxappearance-0.6.3-r2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/harfbuzz:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/pango
+ x11-wm/openbox
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-gtk3
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}