summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild')
-rw-r--r--kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild b/kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild
new file mode 100644
index 000000000000..3596f6d6bd74
--- /dev/null
+++ b/kde-plasma/plasma-pa/plasma-pa-5.15.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_REMOVE_MODULES_LIST=( FindGLIB2 )
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Plasma applet for audio volume management using PulseAudio"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ media-libs/libcanberra
+ media-sound/pulseaudio
+"
+RDEPEND="${DEPEND}
+ $(add_frameworks_dep kirigami)
+ $(add_qt_dep qtquickcontrols)
+ media-libs/libcanberra
+ x11-themes/sound-theme-freedesktop
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.15.4-gsettings.patch" )