summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-nm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /kde-plasma/plasma-nm
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest2
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 0f26d7ed0704..1fa28feb68a2 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,3 +1,5 @@
DIST plasma-nm-5.15.5.tar.xz 777140 BLAKE2B d75ad6c04587f5bc115268f2bef50e0f6dd2b8b86957ab1f43e284988039fb7d9530cb03d86f5c49bdf6747bbb6ad123c7bc527643fe7461ed91efc93c63e563 SHA512 f3f78f40b754de5afbd63c5713e684fe3d37ae25af5a9e6ba808647e0d7d4f23456ed4b94aa8138e1fab99e7f7d7e0dffb697e0e46c99bd312bad5e2a7b9833f
+DIST plasma-nm-5.16.0.tar.xz 782396 BLAKE2B 9ec49f3db478d207c3d44804b1d5fc4f0a8ada1a55e99e4eb2ab8f627523f9aca28f8cf203c6b232cc67709cd90ce17a061edbc3480fad81a1f663306b33c193 SHA512 eeaf8e0a1575c1211311a3996f34cfb4c4065addeb0f72f8a8c83cda79b725def5177f8e531763480a8c28dc5c11b6656ea22871b0e050aa5b84d40de4038ba1
EBUILD plasma-nm-5.15.5.ebuild 1982 BLAKE2B 56527f9910d7ed2ef8d8e3cc13564d4d99cdd5dfa8813f6e22e8ac309adff498a142c2cc7b00ea1e7efd696bc16a2d1a67e1ccbd0ca93e3a0ad0e3585ac8ff65 SHA512 97d12474943bfb5aabed75d3f385a11cf1c4b4d9c6f94fbb3e7c457e0a51cf3bb74f7ef2991199ab1ce026338c00cc57d403ac2576b20924d251cb14c8ef3146
+EBUILD plasma-nm-5.16.0.ebuild 1985 BLAKE2B 37662da4de5f18e91d296b4bb22beb634405104a6dc2b6f092a9ee7fffcc362d8d1005e10028b4e428077078e83fd8d86cfc0fccd4f00c8172a789e7429ac394 SHA512 c79a67b74db0314be108d5e1eefdc8e8fcac66f6dc3d9b396b3d717ace8d1a30e79fb72365eae5c0b42d906106f5e70c6795bf842d56b35a4f8172bbe1302210
MISC metadata.xml 479 BLAKE2B 501f2ff581390f3119e9474e1aeafb45f2e13f3cf25650482f39ab38c7fb0e70ac006f269693ef546ef324730f302c454d27d79f0346e43b6f37583ccad1ca93 SHA512 69a8ce09c5a437814562c315dc7ac3142ac6c71906f37a6ea98e7b76fdd332362cfa76e823d0ee1ec920e92c8f7dda2a557071c758e9937886d7df78943b5689
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}