summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /kde-plasma/plasma-integration
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.16.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 048826298df7..0d6873827c15 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.15.5.tar.xz 55380 BLAKE2B 8388641685477a1778d0ba455c4d2bbff36b0c64224c9a616e6174b1be4e7b7d1b800ac976f1ec90f84ca5945ec4ccac4db5c84d5a3862f6e485d55f8d134486 SHA512 544fce9aae17eb9bbf07267a6d05a8ca34bcb8d33fddb9021dd844e1f20f26df985ddc659b2996be01e49023650893c56748c7d5572810fab7e3e8b6d74b3837
+DIST plasma-integration-5.16.0.tar.xz 55700 BLAKE2B 3f07c12752bef5c9f03e43898812928e26fe8937fec86fa5e370682520b6eaad192d7c416319ed7243fdd4cc234f48b3fe546e8469d9c565a49283e104538299 SHA512 dd11495d338ca4b1b28aaaa3c340cbcf0743c452481b5758480dcc4d6c549dbe68056a5beef8c09119b468e19213f210fb13d1e1b8803f355c194dc51333c12f
EBUILD plasma-integration-5.15.5.ebuild 1058 BLAKE2B d1d62b1350c810f7aac2f1d4666656b566f3e752e771a37f8edfafdc507dcd6249a2fe21fa90fe89fe61aa4b3506afd6a99ac5ec0fea843cf3c0859ae21b1322 SHA512 6762712e8391d4eb0d9812b14caa2009d5d9976820e417150ad363be69f04a19cca3cfe5fca4922b2c4763ed26f48635fac0f746f1cb25d5a4dafa864fec78ad
+EBUILD plasma-integration-5.16.0.ebuild 1061 BLAKE2B de6dba39b5478dfc17cfc75db01423227c38493b7121db0bc60eadbb32ef618ed4e465ad373b86e5e418db261e53f9b634e7b56c6e2e2ac3b8ea99f6fa6ff831 SHA512 acae6a3285cfb9813155eea32abb7593fcf80b547405de1e4603c7509df0078877df4e00c4d7aaceb74bcaba6b6df073214591e99328fc3cabcbb36714fa5bf2
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.16.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.16.0.ebuild
new file mode 100644
index 000000000000..b28163426a43
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"