summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
commitab7810b87f5bb33b3ed5edd0dbda7f4bcd0cf70d (patch)
treef102e6ba13816f35c909cda970653f5422ee1b0d /kde-plasma/plasma-integration
parent6d478a9cbbd774e9d2743701d0931416e3ab9371 (diff)
gentoo auto-resync : 13:09:2023 - 22:45:20
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.27.8.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index dfa5881a657a..912e5fef91be 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.27.7.tar.xz 89868 BLAKE2B fa7ebb82a4327950f56ad4df3eabce3e2d21243371b471c579b5ccffc8d1e441f6f7102a64619aba57bb4c9a232b4548e9372a830002edb18d377b630cf68ea1 SHA512 d24b5d73e6e86967b0b2435e082c3be1433c161c20826ccc68d08777a1acb2d606c3afa89bf2f097f393448bb66d50b93eb0631790fd0990bd270306239a6ac6
+DIST plasma-integration-5.27.8.tar.xz 89908 BLAKE2B 2c7c5f357d4df0617bf7717363569d737cb298293453ceb335b3fdc2fe81fd33cb603d8f87adbfa3a5c5eb6229f3c0cb1b017f752f64e684858af852302a78a5 SHA512 a0405c6bac7606421892bef65b010a9113b02add115cf654d84a7903d2930eb0ee9da4af18d0ef6e4a7f4c09b1594eed4a8ea552a17ce38dd7c86f98c556b543
EBUILD plasma-integration-5.27.7.ebuild 1372 BLAKE2B 0dcf97977c2f880625ff228c2dfcfcc0dace5b45e58942f6a1793d2642b7fcb1601c1450603923d08af2f2c445d9277832cb021419220a5c15ff50d566cce042 SHA512 b78f33c149e1f05a542b266c6d0b682005c0bd18583479407dadaceba5f04a5ce13b83e2b52568186a2112c37cf05582a92705914a599c826943677fa2bec801
+EBUILD plasma-integration-5.27.8.ebuild 1375 BLAKE2B b9d487ac23eab9ca46a23957e8b7443f21ab1e8a279b1dfe3807bc161e994ef515d52667d643946be1207a88d0cf323cb68c2b7e6782a5a31d53d5e31b00b17d SHA512 a4280da692234476526eea2f4e754f0c14a85d36f23a41fe40ba7dda3a43080f33a48e9254f2e616d12e2e140cc6bc9328a0760a4e6fd60fc92037e04db9bdfa
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.27.8.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.27.8.ebuild
new file mode 100644
index 000000000000..948e0e94a4e1
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.27.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+BDEPEND=">=dev-qt/qtwaylandscanner-${QTMIN}:5"