summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 01:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 01:17:50 +0100
commit7d4e34d0bcf06b357fd09a059a02687acf335132 (patch)
tree06974fa0252f3c0c3039ba3f9d4ce051ae11f3f6 /kde-plasma/plasma-integration
parent1941d371dc945a34f7070c341af1392edb5ca3a9 (diff)
gentoo auto-resync : 21:06:2023 - 01:17:50
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.27.6.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 33433812e8d9..5b32f19a4cfa 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.27.5.tar.xz 89436 BLAKE2B 1757501436016e16cceab80ef482e0335438de82a80cbd40e2e1af2ec419ca476fd33994cadcc3c0d68091a9511d3af71f9febdf60b7babc67c3f4cf7ef0bdc9 SHA512 854c35b6159f91c838494912f2defc87b0044845ba98ca2fda83ac141f4214c6d4648e258e2839e01eb9263171896a5686a29d27b95c264026f99756e4aa8268
+DIST plasma-integration-5.27.6.tar.xz 89864 BLAKE2B 2d74409f09384011885a96b26c00a7ea4ddeedbdbe214cb8840b141cb3f223e3d5f4006225dbdd1b11109c53ee4b90adde2c6b8590c72519d658f9832dfc5e39 SHA512 8e86166970f0d2abe60e74492cb98f0230b6b9142880f297f1357fc6aa0be749b1209e95eb646e2955fd183f87c284bdd08e1b2711b50b7766d00eaf9673cf84
EBUILD plasma-integration-5.27.5.ebuild 1397 BLAKE2B 4552eced9166bc0ba2b1fec3c248ac3830bbac33cb4210d0ab8a8d815a62fe3c83e5bebfda767475b15ff15f4cb00ee7d892061692d228f5dc5556d5460aa141 SHA512 57a71fec1cddd9441d11f7800d4b97321b01ca7f8c99a2b87d6e0ff0c1031ec827542254a1bdcd938ab5e5a86e3d1c43936a5db8919906e7aa14725e5e694023
+EBUILD plasma-integration-5.27.6.ebuild 1375 BLAKE2B b9d487ac23eab9ca46a23957e8b7443f21ab1e8a279b1dfe3807bc161e994ef515d52667d643946be1207a88d0cf323cb68c2b7e6782a5a31d53d5e31b00b17d SHA512 a4280da692234476526eea2f4e754f0c14a85d36f23a41fe40ba7dda3a43080f33a48e9254f2e616d12e2e140cc6bc9328a0760a4e6fd60fc92037e04db9bdfa
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.27.6.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.27.6.ebuild
new file mode 100644
index 000000000000..948e0e94a4e1
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.27.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+BDEPEND=">=dev-qt/qtwaylandscanner-${QTMIN}:5"