summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /kde-plasma/plasma-integration
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest2
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.22.90.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 782029a06622..13791b540d3d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,5 @@
DIST plasma-integration-5.22.5.tar.xz 65644 BLAKE2B 5a127c3f8ceb95177447fbbfd29e24ff65aba0dba4373c42ec358f2f0df941baf428962bcc90c25217d843df7c8f896ddf35d6001f575d4d226929a62c514136 SHA512 5da783bc3e32de5e68fb065f7dc014f92216821942b6f2c016fe494915fed1edaaaf88c26cd2a830fa306459e03d63d73dfbc805a845a0ac1f215128aa18df3c
+DIST plasma-integration-5.22.90.tar.xz 83032 BLAKE2B 47b4cf4375ac38a57314cbe564f6a1c3f24e10b82166f0d34b2af6ac0b70176547ecd7c641c4342abf86caeef63a37172751f19eb893d34571d3be7b9742c947 SHA512 1e2b49560144be363f42d37d288b1c88a5fe9338a8d5259ee83fb077348890020fb30824fdb273670d0485c04408471e800526c6f209347a98ccbb1375e2c091
EBUILD plasma-integration-5.22.5.ebuild 1240 BLAKE2B dc987d263b7f78e5d71c3ead5c19726fae2c3c8d0c1e732c0f94837b91a881552367751e0d4eae280e4a5add38b0dae9240159b32cbc2eb4dc7e7efa6e094c07 SHA512 d5db967a46b6fe5b363949c8e93388f7aff6fda0f97351c8b3c889e5a5e417f97ce50f3738e82fbb14ca0f60365873577b461a3a60475671f5a80d73224d9592
+EBUILD plasma-integration-5.22.90.ebuild 1243 BLAKE2B 47a16bbeb4dcc249f6e251d55ed1c908aa58a2b130d65df44886bbc689fb11468497d888d0a5f3aa680435a2fa2675d3537d7530add3fd5b2f28de98f05f4da8 SHA512 d335f3692749183f9245c9d64cc1ae840881da11cb0047bdcf66594a91a7c29ffde0858d7dbe2d0cc8434afa82de6c1f051ab04588e10257446c70330ace1b80
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.22.90.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.22.90.ebuild
new file mode 100644
index 000000000000..2873e4f7febe
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.22.90.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"