summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
commit4b4d352fc9761396c68812d8eccc63b7b14d6558 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild
parenta2c1a301b2ea85c230b30ef69ff667f230a1bf88 (diff)
gentoo auto-resync : 03.08.2022 - 13:42:43
Diffstat (limited to 'kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild')
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild
deleted file mode 100644
index 0161118e86d2..000000000000
--- a/kde-plasma/plasma-firewall/plasma-firewall-5.25.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-KFMIN=5.95.0
-QTMIN=5.15.5
-inherit ecm plasma.kde.org python-single-r1
-
-DESCRIPTION="Plasma frontend for Firewalld or UFW"
-HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
-
-LICENSE="GPL-2+"
-SLOT="5"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
-IUSE="firewalld +ufw"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kauth-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
-"
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}
- firewalld? ( net-firewall/firewalld )
- ufw? ( net-firewall/ufw )
-"
-
-src_prepare() {
- ecm_src_prepare
- # this kind of cmake magic doesn't work for us at all.
- sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
- -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
- -DBUILD_UFW_BACKEND=$(usex ufw)
- )
- ecm_src_configure
-}
-
-pkg_postinst () {
- ecm_pkg_postinst
-
- if ! has_version sys-apps/systemd; then
- ewarn "${PN} is not functional without sys-apps/systemd at this point."
- ewarn "See also: https://bugs.gentoo.org/778527"
- fi
-}