summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
commit97bacba3ead078e5db8b87ab651a3ffa7d82f60f (patch)
treea769244c0cdbaa4ae87951809f61da3a3f9df7a4 /kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild
parentb92911550490e2da121ec4b02d3cf60a2d31a17d (diff)
gentoo auto-resync : 17:04:2024 - 12:04:27
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild
new file mode 100644
index 000000000000..9a1226aaba93
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"