summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 18:46:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 18:46:38 +0000
commitd71aca7673826d5f5fa93b43c7c8af3c1e023dc6 (patch)
tree82fd4c1459b4cdcb08680126fe8ea984e5534645 /kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild
parent0c97119fc8982c1a6f367de25542834e4dd6cda4 (diff)
gentoo auto-resync : 12:03:2024 - 18:46:38
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild
new file mode 100644
index 000000000000..9a1226aaba93
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"