summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 21:24:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 21:24:43 +0000
commit4cf2f7cc6bbea59e8aec44b9508c759cf8bb4adf (patch)
tree839a94b536a4ef1c81281e42bf4be4a80483f24d /kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild
parent867ef65cd897014478ed65034b1ac3f139289a77 (diff)
gentoo auto-resync : 08:11:2022 - 21:24:43
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild
new file mode 100644
index 000000000000..99175ca19edd
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"