summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
commit533ce9c954925ca2a6bccd1f52f266e81e61a678 (patch)
treeef0ef849f69e60394f4bbbab166e6b83848f609c /kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild
parent9a8514e070a40648dbc8e28ad6457d925542b79a (diff)
gentoo auto-resync : 26:10:2022 - 15:55:57
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild
new file mode 100644
index 000000000000..a2eaeae9623a
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"