summaryrefslogtreecommitdiff
path: root/kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild
new file mode 100644
index 000000000000..466f2ec10616
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.24.4-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+ >=dev-libs/wayland-protocols-1.24
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-layer-shell-reset.patch
+ "${FILESDIR}"/${P}-guard-subsurface-parent-access.patch # KDE-bug 452044
+ "${FILESDIR}"/${P}-fix-crash-on-screen-setup-change.patch # KDE-bug 452318
+ "${FILESDIR}"/${P}-fix-race-in-wp_drm_lease_v1.patch # KDE-bug 452435
+)