summaryrefslogtreecommitdiff
path: root/kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild
new file mode 100644
index 000000000000..428f62c44d5a
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.22.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl]
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.3.0
+ >=dev-libs/wayland-protocols-1.18
+"
+BDEPEND="dev-util/wayland-scanner"