summaryrefslogtreecommitdiff
path: root/kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild
new file mode 100644
index 000000000000..1f6fa51fe042
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.21.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-libs/wayland-1.19.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl]
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-libs/wayland-protocols-1.18
+"
+BDEPEND="dev-util/wayland-scanner"