summaryrefslogtreecommitdiff
path: root/kde-plasma/ksysguard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /kde-plasma/ksysguard
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest2
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.6.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 6b34198049c7..098ff9e66139 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,3 +1,5 @@
DIST ksysguard-5.12.5.tar.xz 486676 BLAKE2B 4c706d719920beaf1ec831d23d918a254e01281e89232b1b36e9ca0f5a3134b3b688f7b37af3f41836808a3a3d8ac8052da65df80198ab8ad20fcfa288e868db SHA512 02f5b64a39e395869479ab93ef683136b7017dfb51e55dc03206641bd46052e656547244fc2b6cd86902d5a4f08a5a8fd7d1d5ba0fed73c765a2cfbc39f4bd32
+DIST ksysguard-5.12.6.tar.xz 490700 BLAKE2B 983efe089236f929f0eaef8c43c17a57223c1710d153240b10a76cdacbda974b4c135b3002a89edc72be605fcf07a61e02de9c00aa7291d84777b71190a2e86b SHA512 ca0d21e6ed8fc8b042c6a0fbbfd0fa57811bf0e90da323df32c7905f8ce96155b67916d3038f8a993ab8e12383c1a3131d5d3bfb028cc374ea46129046f5ad81
EBUILD ksysguard-5.12.5.ebuild 1143 BLAKE2B bc2409ea028c763c822431abd58fe334cf5f3ab8430b43ec61cd53336e278f4a8bcb518e01d1de86607053fded35b8924bce024ababea2c904bd89159e57a6cc SHA512 3f50f88f16dde5a45742d8012d5a5601955b59c191aa82d0fa410425fa56e13faf3f8370a4f86d2eceda48790d9ffc12aeaf647a1689f5c1310ade072a8037c3
+EBUILD ksysguard-5.12.6.ebuild 1145 BLAKE2B 46054b5abb67d1b8f049c8bcc974ee3e2bf7c2029c151aa31688cab1b251e2913aa54bc6587361b2b7030ffed33aef8615af3a8d3641f1463458f374f29a635c SHA512 201d5337ec13c6b615401ea9b0ecf478224d454dc6dde1c9defddd9de9a980f9ab9f3b9061e1c3a84a5013cdb0964a7238b4a3b3caf83f741ce8c36fa9247209
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}