summaryrefslogtreecommitdiff
path: root/kde-plasma/ksshaskpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /kde-plasma/ksshaskpass
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest2
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.12.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index d3c2c39fda43..11328af21ebc 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,4 +1,6 @@
AUX 05-ksshaskpass.sh 42 BLAKE2B 2fcef93ed56ab90d98078017924ccfcf3892914e0fc45c6733b538634743a79ae1603da4aabed1c9641750ceae24e167591989290427f6efa4a03b4d69008362 SHA512 780f4d0467bab82295f894f0547ea59c36e8f05cff51c4e64db8a7e8e4215e2d6363550fed16a4336019b2102e5c5bdcfe73524761ba04db3704ddec6efec669
DIST ksshaskpass-5.11.5.tar.xz 23168 BLAKE2B 74d10be7c303d0b7d1d8765e08a89986b4c1745e5f601982dd406cefc7c73ac684c1c05acdd355d45f5078e034ab9971467b4b76c0ae3a94800ce6480fa8c3f0 SHA512 34a8fe5da983a0fcc6d5d223120f2d23e0168a534d29941e83024110eafe981d6c46ee503abfb7bf8e072dc64060eea373c191ef0f8dbc5051cb2d968e6d49d3
+DIST ksshaskpass-5.12.0.tar.xz 21272 BLAKE2B 5b2037c239e0f3697364daa31cc3dfd632f882d4729369a44284601001f44edec1df8ca0b6daddcbde05467196e866513b4cc94d2ad7127462934b315e580462 SHA512 f785f6e58bc580eb2b895bebe2a1d9eaccbb8ad9e493eb8f55ffc86a4dc32d609278fcb351c7b33787471e387eb47e6106ddcd0fe2a8fc27ff59e40a41cc5052
EBUILD ksshaskpass-5.11.5.ebuild 1235 BLAKE2B 76ec180a4af4bf1b0f861f3f86e8ba4df59d796a58bfd95dcf1e1dac2dcf9eb7e7682a714fef94cfbe1609518381e8d812b10f6665d2aa2100b6ac337181f5a7 SHA512 02ef5de19976e1b1aaa20ac0c6534bca3094a4befad0da39d557199455ec37d8f058e5aecea2be2a808bb98d5723ca511147ab7148a205fa39515d960d3b41eb
+EBUILD ksshaskpass-5.12.0.ebuild 1237 BLAKE2B 1c99e53800164ee9b4fc7a1b3f0e455d73731bf4134c4ef564ab87232172821c4f0b21cc6585b71af7260f624fc2e72bf65eb1f464c3cb2306387c41a494eecd SHA512 8dee7f813fb760cabaa932423c2cb099647141f664abdae30996d212226aa9c42f5b683543d021ec2abe48d19086e22a26416806375849c07c0db7900ab5b0ff
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.12.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.12.0.ebuild
new file mode 100644
index 000000000000..3009c8d5ff69
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.12.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}