summaryrefslogtreecommitdiff
path: root/kde-plasma/ksshaskpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /kde-plasma/ksshaskpass
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest2
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.16.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 72c848682a23..611116bd9394 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,4 +1,6 @@
AUX 05-ksshaskpass.sh 42 BLAKE2B 2fcef93ed56ab90d98078017924ccfcf3892914e0fc45c6733b538634743a79ae1603da4aabed1c9641750ceae24e167591989290427f6efa4a03b4d69008362 SHA512 780f4d0467bab82295f894f0547ea59c36e8f05cff51c4e64db8a7e8e4215e2d6363550fed16a4336019b2102e5c5bdcfe73524761ba04db3704ddec6efec669
DIST ksshaskpass-5.15.5.tar.xz 21304 BLAKE2B 8664f783d08d789aab81e40cc6d0a7248f0fe25bab20803579ce0c3869a412d2fc8fecf709b4bfe7d900dc7b9af59042d4e648d5b5730a8fb7108f4ac39ba362 SHA512 296581dafc7068a0e536fb3f10dbd56bd288bec5b93f96e5f7d7b03be6cf9f279dbdeccc8c53da21316fa18d758e92513d8f5441d9e80dfee452c26ef1dddcbc
+DIST ksshaskpass-5.16.0.tar.xz 21364 BLAKE2B 514ca74ab5c52cde2f09dd8791c3c32612d8dfe5a0f3398ff29f6b3122266b894a72a06a2f4b280216786be8022b37236bb394b23f53cef4a45970875814353d SHA512 ebf64d4ce6dcc4036e77affd653201e6fd363257976b4979d84b18c3e60694abcd94dcca2d0a1db16bbe8ece0442bca9d81a1195ab0643f815db93625f3a9a19
EBUILD ksshaskpass-5.15.5.ebuild 1208 BLAKE2B ea2987af04a4d3f03040a66a782090fd7e6be7194b30bb9dadaf2f0bb01e95b12616efa562563f4171ebbb9489828a37dc44416b394b5d242e1c17ec77d4b43b SHA512 a1cddc2234d04f3df3ad15f81c50e2935c752e9913d69da6b0bb6e0c7a1c6319bc63031a33c183d7b66456fc628fd62f166b020db34562aa1ea6ebedb0012306
+EBUILD ksshaskpass-5.16.0.ebuild 1211 BLAKE2B 587e6fc37bb3ecd4f9d3fe17b11cc22228f41dadf34f3fabdf51dcfae453f22dd2a0b63c18897763a62f2ebddf697e6e2ebfbd39429ce99f43efc63f91795947 SHA512 34b197bf82cf085c5fd9c2f5af3ae895260af6ceeaff95e95f46f41116762ef57376fe129ceb27a9c5cbe5cc8f212d9c897555df64a443ca22ca452a9f98fc67
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.16.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.16.0.ebuild
new file mode 100644
index 000000000000..55652bdcf792
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.16.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}