summaryrefslogtreecommitdiff
path: root/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
commit97bacba3ead078e5db8b87ab651a3ffa7d82f60f (patch)
treea769244c0cdbaa4ae87951809f61da3a3f9df7a4 /kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
parentb92911550490e2da121ec4b02d3cf60a2d31a17d (diff)
gentoo auto-resync : 17:04:2024 - 12:04:27
Diffstat (limited to 'kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild')
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
new file mode 100644
index 000000000000..8bd4b1f19279
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}