summaryrefslogtreecommitdiff
path: root/kde-plasma/kinfocenter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /kde-plasma/kinfocenter
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.17.2.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 644a61af64aa..d4c66ce73d02 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,5 +1,7 @@
AUX kcm-about-distrorc 108 BLAKE2B 9324829040a699d8858a739b228b14035f8a33d4cc5e19af30545a6eb9780808b3350ca12c82a44a1868c32acddd76dcdb4e7b25e5792694b55fbb38ed23db8a SHA512 72f1dcaa04bfe435e64c8e584914eb56a15b63f7c6086f5e025f0c497b4fd5b9592d54aafd335f55d303790af274c9cbfa29c6c7ff87875da648ee16d7717467
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.16.5.tar.xz 1321040 BLAKE2B b8c1e699d23175bc1048233aa589e91c31625f8a93da2b3ade5f71bf410723c853f2b4f0654a78be1f2c7a2350e66a8f932c4c0c7db9bbc2c22ac3ef9ff5b2a6 SHA512 1b98515beac87ff5394c06dd6029a2688db27a900f4c85fd4884d332a20120d553c25b98ae5ccfd7da2e6cbaa866edb84809f49c1c19922f25241acdc9e56832
+DIST kinfocenter-5.17.2.tar.xz 1344056 BLAKE2B e40dc6efc8df24f0c868232fc67e02cdad189d124a3b3460cd1855949306b806c41fe54f8d554ff8da7aa255e7078899641696c1dd6f524b12c1762c81102fb0 SHA512 aeb1b61f2ab198ceeaead3873659df5901740e9bd80f03a34bb955a6c172c0f3f31ba54d51a2b7cc9f827128c4a9161a841eecbb49be2ecde58be62f4319d2d4
EBUILD kinfocenter-5.16.5.ebuild 2556 BLAKE2B faf8debb2bb55b8d742c620a6daa1dacadf88e1f66b774dfde845bd4a76c52f7130b8ddfd3cf854ca21d1aa8bccc162b0ffca7498fd2995a3becd0901314402d SHA512 bdfb961e33a46ca05cb0530084aa576d92353c676e4726df7ea953545a7b627fb3f65e71d3f64a156a0c7d76541fb1c20f5289d5b7aea0a2df8570f565c4bc92
+EBUILD kinfocenter-5.17.2.ebuild 2559 BLAKE2B 3f11ac44d0cbc64aa532d6da8c500050777a24063bdd6b6aec7e375561d49e85a5884e288acfc9a9a4924acdb8e211332120f3d37b2e99575ccd388f5daad65b SHA512 ed2481b3a29e22a27284a42137ea18f87f9802331956d2de129b66cd0fb2529d5a5a44a141153a61c18a35cd2c78faec038785f1fa4420ca05ddc77b5d9c36f3
MISC metadata.xml 390 BLAKE2B a47af94b17ade0ad2f4b4a44bac8ac1245c29a6551a059c95967ce2d5cd4420a975210bf0e4658c2152aaf5a894f934cac0d35aae015368bf1f8f8b1cbbbb069 SHA512 4ea690f0f5ac41b58d840949297d462e0fa7433bdece54d63b08a913d8a9001bf6d144e28d5e672712abf35e784c2b17faf31f0a879d6109417ce95ccdc0ef3b
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.17.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.17.2.ebuild
new file mode 100644
index 000000000000..7bfec63201e8
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.17.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MIN_VERSION=3.14.3
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?,X(+)]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}