summaryrefslogtreecommitdiff
path: root/kde-plasma/drkonqi/drkonqi-5.13.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /kde-plasma/drkonqi/drkonqi-5.13.5.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'kde-plasma/drkonqi/drkonqi-5.13.5.ebuild')
-rw-r--r--kde-plasma/drkonqi/drkonqi-5.13.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/drkonqi/drkonqi-5.13.5.ebuild b/kde-plasma/drkonqi/drkonqi-5.13.5.ebuild
new file mode 100644
index 000000000000..08c83e00ef5a
--- /dev/null
+++ b/kde-plasma/drkonqi/drkonqi-5.13.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Plasma crash handler, gives the user feedback if a program crashed"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlrpcclient)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/drkonqi:4
+ !<kde-plasma/plasma-workspace-5.10.95:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X Qt5X11Extras)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ if ! has_version "sys-devel/gdb"; then
+ elog "For more usability consider installing the following package:"
+ elog " sys-devel/gdb - Easier debugging support"
+ fi
+}