summaryrefslogtreecommitdiff
path: root/kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild')
-rw-r--r--kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild b/kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild
new file mode 100644
index 000000000000..70204ef4d2c8
--- /dev/null
+++ b/kde-misc/zanshin/zanshin-0.4.1_p20171231.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=6239128a6c6693e71def64e9782f31bdd9621d19
+KDE_APPS_MINIMAL="17.12.0"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Getting things done application by KDE"
+HOMEPAGE="https://zanshin.kde.org/"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# FIXME: bundles libkdepim
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kldap)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ test? ( $(add_kdeapps_dep akonadi 'tools') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/zanshin:4
+ $(add_kdeapps_dep kdepim-runtime)
+"