summaryrefslogtreecommitdiff
path: root/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild')
-rw-r--r--kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild
new file mode 100644
index 000000000000..a39961d2e0a6
--- /dev/null
+++ b/kde-misc/kmarkdownwebview/kmarkdownwebview-0.5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit ecm kde.org
+
+DESCRIPTION="KPart for rendering Markdown content"
+HOMEPAGE="https://frinring.wordpress.com/2017/09/14/kmarkdownwebview-0-1-0/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kparts:5
+ kde-frameworks/kxmlgui:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QTWEBKIT=OFF
+ )
+ ecm_src_configure
+}